Payroll and benefit admin slowdown reported
Incident Report for Namely
Resolved
This incident has been resolved.
Posted about 1 year ago. Nov 21, 2016 - 18:16 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 year ago. Nov 21, 2016 - 17:43 EST
Identified
The issue has been identified and should be resolved shortly.
Posted about 1 year ago. Nov 21, 2016 - 17:43 EST
Investigating
We are experiencing degraded services at the moment with our Payroll and Benefit admin services.
Posted about 1 year ago. Nov 21, 2016 - 17:27 EST