Namely Services outage
Incident Report for Namely
Resolved
Issue is resolved. All systems online and responsive.
Posted almost 2 years ago. Aug 09, 2016 - 16:30 EDT
Investigating
We are investigating reports of Namely services being down.
Posted almost 2 years ago. Aug 09, 2016 - 14:52 EDT