Issues reported with the benefits enrollment wizard
Incident Report for Namely
Resolved
This incident has been resolved.
Posted 7 months ago. Sep 18, 2017 - 18:07 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 7 months ago. Sep 18, 2017 - 18:01 EDT
Investigating
We are currently investigating issues reported with the benefits enrollment wizard.
Posted 7 months ago. Sep 18, 2017 - 17:38 EDT