Intermittent issues with payroll
Incident Report for Namely
Resolved
This incident has been resolved.
Posted about 1 year ago. Dec 12, 2016 - 21:27 EST
Identified
Namely Payroll will be down for emergency maintenance at 8:30 PM ET
Posted about 1 year ago. Dec 12, 2016 - 20:42 EST
Investigating
Intermittent issues with payroll have been reported we are currently investigating.
Posted about 1 year ago. Dec 12, 2016 - 11:51 EST