HRIS login Issue reported
Incident Report for Namely
Resolved
This incident has been resolved.
Posted 9 months ago. Apr 18, 2017 - 19:13 EDT
Monitoring
At 3:08 PM EST, we received our first report of inability to log-in to our HRIS site. After investigating, we have resolved this issue at 3:40 PM EST and are closely monitoring this fix.
Posted 9 months ago. Apr 18, 2017 - 15:41 EDT