Namely is investigating reports of intermittent slowness in calculating payroll.
Incident Report for Namely
Resolved
Payroll Calculation issues are now resolved as of 2/28/18 at 1:40pm ET.
Posted 3 months ago. Feb 28, 2018 - 13:40 EST
Investigating
Namely is investigating reports of intermittent slowness in calculating payroll.
Posted 3 months ago. Feb 28, 2018 - 11:11 EST