Data Sync Delays
Incident Report for Namely
Resolved
Namely has confirmed data syncing is now performing normally.
Posted 6 months ago. Jun 04, 2018 - 14:08 EDT
Investigating
Namely is currently investigating reports of data syncing delays across the platform.
Posted 6 months ago. Jun 04, 2018 - 13:04 EDT
This incident affected: Namely Services.