Intermittent Slowness
Incident Report for Namely
Resolved
Namely has confirmed the slowness is resolved as of 8:44pm ET.
Posted 3 months ago. Jun 27, 2018 - 20:44 EDT
Investigating
Namely is investigating reports of intermittent slowness across the site.
Posted 3 months ago. Jun 27, 2018 - 19:20 EDT
This incident affected: Namely Services.