System slowness
Incident Report for Namely
Resolved
Network latency issues are now resolved as of 10/11, 6:00am ET
Posted about 1 year ago. Oct 11, 2017 - 08:41 EDT
Identified
Namely is currently diagnosing and actively addressing the site-wide slowness
Posted about 1 year ago. Oct 04, 2017 - 20:12 EDT