Intermittent Slowness
Incident Report for Namely
Resolved
All reports of intermittent slowness in the platform are now resolved as of 3/2/2018 5:16 pm ET
Posted 7 months ago. Mar 02, 2018 - 17:16 EST
Investigating
Namely is investigating reports of intermittent slowness in the platform.
Posted 7 months ago. Mar 02, 2018 - 15:57 EST