Intermittent Slowness
Incident Report for Namely
Resolved
All reports of intermittent slowness are now resolved as of 10/1/2018 11:57 am ET.
Posted 3 months ago. Oct 01, 2018 - 11:57 EDT
Investigating
Namely is investigating reports of intermittent slowness across the site.
Posted 3 months ago. Oct 01, 2018 - 11:02 EDT
This incident affected: Namely Services.