Updates to Employee Banking Information Unavailable
Incident Report for Namely Site
Resolved
This incident has been resolved.
Posted Jul 11, 2023 - 15:13 EDT
Identified
Namely will be unavailable tonight from 9 PM ET to 10 PM ET due to system maintenance.
Posted Jul 10, 2023 - 17:37 EDT
Investigating
We are currently investigating an issue impacting the Banking Information tab of the employee profile. The ability to make and save changes to employee banking information is currently unavailable.
Posted Jul 10, 2023 - 08:43 EDT
This incident affected: Namely Services.