Intermittent Slowness
Incident Report for Namely
Resolved
All reports of intermittent slowness are now resolved as of 7/23/2018 7:44 pm ET.
Posted 3 months ago. Jul 23, 2018 - 19:44 EDT
Investigating
Namely is actively investigating reports of intermittent slowness across the site.
Posted 3 months ago. Jul 23, 2018 - 15:45 EDT
This incident affected: Namely Services.